error to run POLYMER v4.11

lzoffoli
Posts: 7
Joined: Fri Jul 12, 2019 9:51 am
company / institution: Universite de Nantes
Location: Nantes

Re: error to run POLYMER v4.11

Post by lzoffoli » Mon Aug 26, 2019 12:39 pm

Hi Francois,
yes, here they are:
export PATH=/home/laura/seadas-7.5.3/bin:$PATH
export OCSSWROOT=/home/laura/seadas-7.5.3/ocssw
source $OCSSWROOT/OCSSW_bash.env

and I have another one not related to seadas but to conda:
export PATH="/home/laura/anaconda3/bin:$PATH"

best,
Laura
User avatar
fsteinmetz
Site Admin
Posts: 48
Joined: Fri Sep 07, 2018 1:34 pm
company / institution: Hygeos
Location: Lille, France
Contact:

Re: error to run POLYMER v4.11

Post by fsteinmetz » Wed Aug 28, 2019 9:36 am

Hi Laura,

I have similar lines in my .bashrc.
However in my case, PROJ_LIB points to the anaconda directory:

Code: Select all

% env | grep PROJ
PROJ_LIB=/home/applis/anaconda/envs/py3v19.04/share/proj
_CONDA_SET_PROJ_LIB=/home/applis/seadas/v7.5.3/ocssw//opt/share/proj
Maybe is there an issue with your anaconda installation ?
Could you try by commenting the seadas related lines in your bashrc ?

Also, the following command should be a minimal test for the failure you are having: python -c 'import pyproj ; pyproj.test()'
lzoffoli
Posts: 7
Joined: Fri Jul 12, 2019 9:51 am
company / institution: Universite de Nantes
Location: Nantes

Re: error to run POLYMER v4.11

Post by lzoffoli » Wed Aug 28, 2019 12:02 pm

Hi Francois,
I followed your recommendations but nothing changed.
So, I decided to reinstall all the packages required in the polymer README file, into the directory /home/laura/anaconda3/lib/python3.6

After that, I don't receive any error related with pyproj but it changed to:

Traceback (most recent call last):
File "/home/laura/polymer-v4.11/polymer_cli.py", line 11, in <module>
from polymer.main import run_atm_corr, Level1, Level2
File "/home/laura/polymer-v4.11/polymer/main.py", line 18, in <module>
from polymer.polymer_main import PolymerMinimizer
ImportError: No module named polymer_main

Thanks a lot for your patience and help!!
Laura
User avatar
fsteinmetz
Site Admin
Posts: 48
Joined: Fri Sep 07, 2018 1:34 pm
company / institution: Hygeos
Location: Lille, France
Contact:

Re: error to run POLYMER v4.11

Post by fsteinmetz » Wed Aug 28, 2019 2:33 pm

Ok, great to see this is solved.
For your last error message, I guess you forgot to compile the program :)
Post Reply