polymer v4.10 installation

Post Reply
rifat
Posts: 2
Joined: Wed Mar 06, 2019 4:08 pm
company / institution: Remote Sensing of Water Systems, University of Zurich
Location: Zurich, Switzerland

polymer v4.10 installation

Post by rifat » Mon Mar 11, 2019 1:47 pm

Hi,
I am trying to install polymer v4.10 through these commands but every time I got these errors

1) python -m pip install C:\dir\polymer-v4.10.tar.gz
Failed building wheel for Polymer
error: command 'cl.exe' failed: No such file or directory

2) C:\dir\Anaconda3\python.exe -m pip install C:\dir\polymer-v4.10.tar.gz
Failed building wheel for Polymer
error: command 'cl.exe' failed: No such file or directory

I am using python 3.6

Any help would support a lot.

Best
rif
User avatar
fsteinmetz
Site Admin
Posts: 50
Joined: Fri Sep 07, 2018 1:34 pm
company / institution: Hygeos
Location: Lille, France
Contact:

Re: polymer v4.10 installation

Post by fsteinmetz » Mon Mar 11, 2019 2:46 pm

Dear Rif,

Polymer is not provided as a pip bundle. You have to uncompress the tar.gz archive first. On windows you can use for example 7-zip and then find some help in the README file.
However, the primary operating system for Polymer is linux. Issues are likely if you try to run it on windows, regarding the use of gnu make, the compiler, etc. You may get it to work, but it may also be easier to run it on linux, possibly via a virtual machine.
I hope this helps.
rifat
Posts: 2
Joined: Wed Mar 06, 2019 4:08 pm
company / institution: Remote Sensing of Water Systems, University of Zurich
Location: Zurich, Switzerland

Re: polymer v4.10 installation

Post by rifat » Tue Jun 11, 2019 4:55 pm

Hi, I have tried to install polymer v4.11 in linux within anaconda. But i have the gcc error while i am trying to install setup.py.

I installed gcc, cython with gcc 7, and numpy with gcc 7. And I tried it again but the error is same.
Can you help me?

Please see the error massage below

running install
running build
running build_ext
building 'polymer.clut' extension
gcc -pthread -B /home/rifat/anaconda3/envs/polymer/compiler_compat -Wl,--sysroot=/ -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -I/home/rifat/anaconda3/envs/polymer/lib/python3.6/site-packages/numpy/core/include -I/home/rifat/anaconda3/envs/polymer/include/python3.6m -c build/polymer/clut.c -o build/temp.linux-x86_64-3.6/build/polymer/clut.o
In file included from /home/rifat/anaconda3/envs/polymer/lib/python3.6/site-packages/numpy/core/include/numpy/ndarraytypes.h:1822:0,
from /home/rifat/anaconda3/envs/polymer/lib/python3.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:12,
from /home/rifat/anaconda3/envs/polymer/lib/python3.6/site-packages/numpy/core/include/numpy/arrayobject.h:4,
from build/polymer/clut.c:611:
/home/rifat/anaconda3/envs/polymer/lib/python3.6/site-packages/numpy/core/include/numpy/npy_1_7_deprecated_api.h:17:2: warning: #warning "Using deprecated NumPy API, disable it with " "#define NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION" [-Wcpp]
#warning "Using deprecated NumPy API, disable it with " \
^
gcc -pthread -shared -B /home/rifat/anaconda3/envs/polymer/compiler_compat -L/home/rifat/anaconda3/envs/polymer/lib -Wl,-rpath=/home/rifat/anaconda3/envs/polymer/lib -Wl,--no-as-needed -Wl,--sysroot=/ build/temp.linux-x86_64-3.6/build/polymer/clut.o -o build/lib.linux-x86_64-3.6/polymer/clut.cpython-36m-x86_64-linux-gnu.so
/home/rifat/anaconda3/envs/polymer/compiler_compat/ld: cannot find -lpthread
/home/rifat/anaconda3/envs/polymer/compiler_compat/ld: cannot find -lc
collect2: error: ld returned 1 exit status
error: command 'gcc' failed with exit status 1
User avatar
LaurentWandrebeck
Site Admin
Posts: 8
Joined: Fri Sep 07, 2018 1:07 pm
company / institution: HYGEOS

Re: polymer v4.10 installation

Post by LaurentWandrebeck » Wed Jun 12, 2019 11:17 am

Hi rif,

If you are using CentOS:
You need to install glibc-headers and glibc-devel:
(as root)

Code: Select all

yum install glibc-headers glibc-devel -y
If you are using Ubuntu:

Code: Select all

apt install libc6-dev -y
If you are using any other platform, you have to find out which packages provide libc.so and libpthread.so and install it.

I think that should solve your problem, if you meet any other, feel free to come back to us !
Laurent Wandrebeck
IT Manager
jcardoso
Posts: 6
Joined: Fri Feb 08, 2019 10:17 am
company / institution: Royal Belgian Institute of Natural Sciences
Location: Brussels

Re: polymer v4.10 installation

Post by jcardoso » Mon Jun 17, 2019 2:36 pm

Hello Laurent,

I installed the Polymer v4.11 in my Linux (Ubuntu 18.04) and its working fine.
I think you are trying to install the packages using pip or other installation command, if I understood right.
What worked for me was to create a new environment in my Anaconda and inside this environment I used the specific Anaconda install packages available inside the Polymer folder. Doing this you avoid to update or downgrade packages. Then to continue you activate the environment and continue the installation.

Good luck,
Joao.
Post Reply