run landsat8 error

Post Reply
lanzhiqishi
Posts: 28
Joined: Fri May 22, 2020 7:00 pm
company / institution: university of maine
Location: maine

run landsat8 error

Post by lanzhiqishi »

dear everyone,

when i run polymer 4.13 on linux centos , it works very well for sentinel2 , but when i try landsat8 level1 collection2 , it error. anyone help? thanks


best

binbin

my error :

(binbin1) [bjiang@katahdin polymer-v4.13]$ python runPolymer.py
Reading coordinates from /home/bjiang/ningde/landsat8/orgin/LC08_L1GT_118042_20140309_20200911_02_T2/LC08_L1GT_118042_20140309_20200911_02_T2_B1.TIF
Image size is 7731x7881
Traceback (most recent call last):
File "runPolymer.py", line 19, in <module>
Level1_OLI('/home/bjiang/ningde/landsat8/orgin/LC08_L1GT_118042_20140309_20200911_02_T2'),
File "/home/bjiang/software/pythondepen/polymer-v4.13/polymer/level1_landsat8.py", line 142, in __init__
self.init_meta()
File "/home/bjiang/software/pythondepen/polymer-v4.13/polymer/level1_landsat8.py", line 169, in init_meta
self.data_mtl = read_meta(file_mtl)['L1_METADATA_FILE']
KeyError: 'L1_METADATA_FILE'
User avatar
fsteinmetz
Site Admin
Posts: 249
Joined: Fri Sep 07, 2018 1:34 pm
company / institution: Hygeos
Location: Lille, France
Contact:

Re: run landsat8 error

Post by fsteinmetz »

Dear Binbin,

Please try lastest Polymer release v4.14, just released, which should work for Landsat8 collection 2 files.
Cheers,
François
Post Reply