Page 1 of 1

Polymer installation

Posted: Wed Jul 03, 2019 6:29 pm
by user619
I am trying to run the command ./ <level1> <level2> command I get error:
File "./", line 11, in <module>
from polymer.main import run_atm_corr, Level1, Level2
File "/polymer/", line 8, in <module>
from polymer.luts import read_mlut_hdf, Idx
File "/polymer/", line 20, in <module>
from scipy.interpolate import interp1d
File "/miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/interpolate/", line 175, in <module>
from .interpolate import *
File "/miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/interpolate/", line 32, in <module>
from .interpnd import _ndim_coords_from_arrays
File "interpnd.pyx", line 1, in init scipy.interpolate.interpnd
File "/miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/spatial/", line 98, in <module>
from .kdtree import *
File "/miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/spatial/", line 8, in <module>
import scipy.sparse
File "/miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/sparse/", line 231, in <module>
from .csr import *
File "/miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/sparse/", line 15, in <module>
from ._sparsetools import csr_tocsc, csr_tobsr, csr_count_blocks, \
ImportError: /miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/special/../../../../ version `CXXABI_1.3.9' not found (required by /miniconda/envs/vir_env/lib/python2.7/site-packages/scipy/sparse/

I have installed all the dependencies using the following commands:
make auxdara_all

However, I am unable to run the algorithm. Can someone please suggest something?


Re: Polymer installation

Posted: Thu Jul 04, 2019 7:52 am
by LaurentWandrebeck
Hello npal,

Could you tell me:
  • OS used and its version
  • gcc/g++ version used (gcc --version and g++ --version)
It looks likely you’re hitting something like ... -not-found

Hope that helps.

Re: Polymer installation

Posted: Mon Jul 08, 2019 1:58 pm
by user619
Hi Laurent,

My OS is Linux and the gcc version is 4.8.5.


Re: Polymer installation

Posted: Wed Jul 10, 2019 1:36 pm
by LaurentWandrebeck
Hi npal,

So I guess you’re using CentOS (or RHEL, or Scientific Linux) 7.x.

Do you have installed some redhat devtoolset or any other gcc version that could have been used during installation of polymer ?

The error message looks like there were some heavily modified environment used during installation process.

Hope that helps,

Re: Polymer installation

Posted: Sun Jul 14, 2019 1:33 pm
by fsteinmetz
Dear Npal,

In case you are still stuck on this issue, you could maybe try installing an envionment with python3, which is recommended anyway over python2 (and I realize that I should update the installation script to more explicitly create an environement with python3). For that, just use the following command to create the new environment (replace <envname> by the name of your choice) :

Code: Select all

conda create -n <envname> python=3
Then you can use the script as you did previously.