Sentinel 2 - missing 4 bands

Post Reply
federica.braga
Posts: 2
Joined: Mon Sep 23, 2019 2:59 pm
company / institution: ISMAR-CNR
Location: Venica

Sentinel 2 - missing 4 bands

Post by federica.braga » Fri Oct 04, 2019 10:15 am

Hello,

I am using POLYMER 4.12 for Sentinel 2 data. We run Polymer using Level1_MSI or just Level1, but in the output that we obtained bands 842, 945, 1375 and 2190 are missing. Especially B08 is what is important for us...
What could be wrong in our setting?
Did anyone else had the same issue and if so, how did you solve it?

Thank you in advance.

Cheers,
Federica
User avatar
fsteinmetz
Site Admin
Posts: 50
Joined: Fri Sep 07, 2018 1:34 pm
company / institution: Hygeos
Location: Lille, France
Contact:

Re: Sentinel 2 - missing 4 bands

Post by fsteinmetz » Fri Oct 04, 2019 11:26 am

Dear Federica,

Indeed these bands are not included by default. To include band 842, pass the following argument to run_atm_corr :

Code: Select all

run_atm_corr(..., bands_rw=[443,490,560,665,705,740,783,842,865,         1610,    ])
I will make it default in the next polymer release.
You could do the same for the other bands, but the results wouldn't be meaningful, as B9 is affected by absorption by water vapour, B10 is the cirrus band and for B12, using polymer's result will certainly be worse than assuming that Rw(2190)=0.

Cheers,
François
federica.braga
Posts: 2
Joined: Mon Sep 23, 2019 2:59 pm
company / institution: ISMAR-CNR
Location: Venica

Re: Sentinel 2 - missing 4 bands

Post by federica.braga » Tue Oct 22, 2019 11:09 am

Thank you so much François!
I apologise for not having written to thank you before.
I made several attempts and finally I changed the params file. Now I have the B8!

thanks

cheers
Federica
Post Reply